Page 1 of 1

Loosing Steps?!?

PostPosted: Thu Dec 27, 2012 9:32 pm
by beentheunseen
Hi all,

I have been converting an old Universal Laser Systems 25A machine to run on glass Chinese tubes and LinuxCNC ( Everything has gone great so far, and it's almost completely up and running, but I just have one very annoying problem I can't solve. It seems to be loosing its position very slightly on both axes, which is not a huge problem for on large projects, but for more detailed engraving it is more significant. It doesn't seem to be cumulatively building up a large positioning error, as it only seems to wander out of position by a maximum of around 1 or 2 mm even on complex jobs. However it does seem to be quite random - if i start the same job a few times it wanders off in a different direction each time. The strange thing is that If I do a test where i fire the laser at a point, then jog the position backwards and forwards a few times, then return it to the same point and fire the laser again, It always lines up with the original mark, even when I leave it jogging backwards and forwards for a while. However, when I run a program that contains a circle, the end of the circle does not meet the start.

I'm using a simple parallel port breakout board with no opto-isolation, and the motors are being driven by 2 pololu stepper drivers on a 24 volt supply. The belts are tight and the axes are mechanically rigid, so I am confident that I am not suffering from any significant backlash, and I have tried increasing the motor torque and also dropping the max speed/acceleration to make sure I am not loosing any steps through inertia.

I have also been experimenting with the motor timing settings. For pololu drivers a step time/space of 1000/1000 ns and direction hold/setup of 200/200 ns are recommended. However, I have tried increasing the step time/space to ensure my drivers are not missing steps, and have tried increasing the direction hold/setup to ensure the direction changes are not overlapping any step signals. My system seems to be able to support a base period jitter of around 22000ns, but i have tried increasing this as high as 30000ns to be sure. I have also started to look at the steps in halscope:


One thing that does seem slightly odd to me here is that the steps don't seem to be uniform in length. Is this normal?

I also tried making the wires between the breakout board and steppers much shorter to ensure they are not picking up any noise, and have introduced decoupling capacitors to the drivers +5v and +24 supply. I have also rewired all my earths to the same point to make sure there are no ground loops.

Can anybody help me out? This problem is driving me mad, and nothing I do seems to make a difference.

Cheers, Ben

Re: Loosing Steps?!?

PostPosted: Thu Dec 27, 2012 11:25 pm
by BenJackson
So 1 axis moves are OK, but 2 axis moves lose steps?

Re: Loosing Steps?!?

PostPosted: Fri Dec 28, 2012 12:55 am
by beentheunseen
I just did some more tests, please see the image below. It's strange, in the straight line test I did, I do seem to have movement in the X axis (left/right), even where the movement should only be happening in the Y (up/down) axis!


Re: Loosing Steps?!?

PostPosted: Fri Dec 28, 2012 2:10 am
by BenJackson
What's your cabling like? What's your stepper driver? Sounds like you have noise from one set of step signals bleeding into the other.

Re: Loosing Steps?!?

PostPosted: Tue Jan 01, 2013 5:19 pm
by lasersafe1
It might be something simple in the setup. Generally stepper drivers will wait for the rising edge of the step pulse and then look at the direction bit to see if it is high or low to decide the direction to send the motor. This is why it doesn't matter if you see varying widths of the step pulse. If you have your logic backwards through an intermediate buffer card or something in the setup, you may be stepping on the falling edge of the original signal. This causes a gradual loss of steps over multiple cycles because the PC or DSP "thinks" it is done moving the stage and relaxes the step and or direction bit, but the stage was still one step behind.

Since you said that the direction can "wander", I'm betting you need a stronger pullup or pulldown. It could be your parallel port hardware is not up to the task and you may need a buffer card to sharpen the edges.

You are going to love the ULS-25. I rebuilt mine a few years back. Don't know if you saw the buildlog.

Re: Loosing Steps?!?

PostPosted: Thu Jan 03, 2013 9:39 pm
by beentheunseen
Thanks for the tips! I think I may have traced the problem to some mechanical looseness in the Y axis, compounded by overheating stepper drivers. Once I had fixed the play in the Y axis, all seemed to be fine until the machine had been running for while, when there would suddenly be a burst of wandering before it would settle down again. I think the heat transfer tape I was using on my pololus was rubbish as I replaced it with some cpu thermal paste, and the repeatability was starting to look spot on. Unfortunately a belt then failed, so I won't know for sure until the replacement arrives...

Lasersafe1, I did indeed see your build. Between your build and 'sliptonic's build I got a lot of good ideas for mine ( I'm looking for a source of spare parts at the moment, as a couple of my bearings are a little tired. I suspect that in your version of the machine te bearings may be a little different, but do you have any tips for me?