Page 1 of 1

External Thermocouple board & RAMPS

PostPosted: Sat Jun 08, 2013 11:08 pm
by jdm90
I am trying to get the External Thermocouple Board 1.0 running with RAMPS and I can't get it running right.

I am using:

I hooked it up to my RAMPS 1.4 according to this diagram: ... p_to_RAMPS

I set the appropriate configuration.h and pins.h lines according to this section: ... _in_Marlin

Yet, I get a reading of 480C for room temperature. The my multimeter reads the signal output voltage of ExtThermoCouple board in the 200-220mV range, which I interpret to mean 20 to 22C, which is about right for the room. I've tried this on RAMPS boards of two different makes, and with an Arduino Mega and a Taurino Classic, to the same results.

I haven't found any other resources to help me resolve this issue in making it work.

Re: External Thermocouple board & RAMPS

PostPosted: Sun Jun 09, 2013 6:32 pm
by jdm90
Nevermind, I didn't set the correct line in pins.h because I was in the wrong section, basically set it for the wrong board.

It works fine now.

Re: External Thermocouple board & RAMPS

PostPosted: Mon Aug 12, 2013 2:15 am
by gadgetmiser
Hi JDM, I have exactly your problem! Same TC Amplifier, using RAMPS (but repetier firmware).

I'm sure I have made the right edit to pin.h (I am using repetier, but also tried marlin - same result). My TC is showing 499degs C when first turned on, and printer goes to "dry run" mode :(

I would greatly appreciate it if you could show where you made the changes you made to configuration.h and pin.h , which solved the problem for you.