Strange error with Ramps / Pronterface

General discussion of 3D printers

Strange error with Ramps / Pronterface

Postby vgordin » Mon Jun 10, 2013 7:58 pm

I just switched out the printrboard on my Ord Bot to a Ramps 1.4 + Display setup from reprapdiscount. I flashed the latest marlin onto it and the display shows all of the correct status info, but when I try to connect over USB, this is what I get.

http://imgur.com/X3fOm9D

Any help would be hugely appreciated.

-V
vgordin
 
Posts: 40
Joined: Mon Dec 24, 2012 6:05 pm

Re: Strange error with Ramps / Pronterface

Postby vgordin » Mon Jun 10, 2013 8:50 pm

someone on reddit resolved it.... wrong baud rate.
vgordin
 
Posts: 40
Joined: Mon Dec 24, 2012 6:05 pm

Re: Strange error with Ramps / Pronterface

Postby vgordin » Tue Jun 11, 2013 1:57 pm

The fun continues.....

So I got my board (Ramps 1.4) connected. Now, when I try to jog in any direction and any distance, the motors just run without stopping until I hit reset on the board or cut power.

Thoughts?
vgordin
 
Posts: 40
Joined: Mon Dec 24, 2012 6:05 pm

Re: Strange error with Ramps / Pronterface

Postby vgordin » Tue Jun 11, 2013 2:02 pm

Also, when I jog the Z axis, the Z axis moves. When I home the z-axis, the y axis moves in the y+ direction. Wtf.
vgordin
 
Posts: 40
Joined: Mon Dec 24, 2012 6:05 pm

Re: Strange error with Ramps / Pronterface

Postby cvoinescu » Tue Jun 11, 2013 4:38 pm

Check your limit switches. If they're wired incorrectly, or the configuration doesn't match the wiring, all sorts of weird things will happen. Use M119 to see the status that the board sees. Issue that command while pressing and releasing each switch, and check the results. Check that they are assigned to the correct pins in config.h. If not using the limit switches yet, it's important that you disable them in config.h -- set them to (-1). Actually, it would be a good idea to start with all limit switches disabled, just to eliminate them as a possible cause. Once the machine jogs the way you expect it, you can configure the limit switches, knowing that any weird behaviour is because of them.
cvoinescu
 
Posts: 501
Joined: Thu Aug 09, 2012 9:12 am
Location: Camberley, Surrey, UK


Return to 3D Printer General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron