Z axis limit switch question.

Discussions and help on this commercial controller.

Moderator: twehr

Z axis limit switch question.

Postby reeser » Fri May 01, 2015 6:47 pm

I have an LO-X7 DSP controller. I have Z+ and Z- limit switches installed. The switches are wired Normally Open.
When I activate the switch the 24V on the DSP goes to zero as it should, but it has no effect on stopping the stepper motor.
I have the hardware limit box checked on the Manufacturers parameter sheet.
The Z- switch does work to reset Z if I enable Z axis home on power up, but it won't function as a simple limit (+ or-).
What am I doing wrong or what am I overlooking.
I have the same issue with X+ and Y+ not working as simple limit switches. X- and Y- work fine as homing switches but not as end limit switches.

I must be missing something pretty fundamental but I'm kind of at a loss.

Anybody help?

Posts: 37
Joined: Mon Dec 22, 2014 3:08 am

Re: Z axis limit switch question.

Postby sshwarts » Mon May 04, 2015 2:04 pm

What is doing exactly? Is it trying to run past the limit switches? Interesting that you had limit switch problems before that were solved by swapping the motor controllers.

Posts: 93
Joined: Tue Apr 22, 2014 6:37 pm

Re: Z axis limit switch question.

Postby reeser » Tue May 05, 2015 1:27 pm

Hi Scott:

Thanks for the reply.
I think I pretty much described what's going on in my original post. I have limit switches installed at X+,X-,Y+,Y-,Z+ and Z-. The X- and Y- are my homing switches and they work fine.(That was the problem I was having earlier before I changed stepper drivers). If I check the box in LaserCad to home the Z axis on startup it also works correctly.
With the Hardware Limit Box checked in LaserCad the X+, Y+ and Z+ switches don't function at all. I have the switches wired Normally Open. When I check the voltage on the DSP between ,say, Z+ and ground I have 24V as you would expect. When I toggle the switch to close it the voltage goes to 0 as I would expect. The problem is the motor doesn't stop. The same thing happens on all the other axes when trying to use the limits as safety end stops. The thing that confuses me is why they will work as homing switches but not as end stop switches. I suspect I don't have something correct in my DSP setup but I don't now what. I have also had trouble keeping the hardware limit box in LaserCad to stay checked. This is apparently a problem of some type and there are a couple of references to this problem on the LightObject Forum.
At the moment I have set "soft limits" in LaserCad for the X and Y and am using the Z axis with no limits and just being careful, so the problem isn't critical to run the Laser but it's annoying that I can't seem to fix it :) .
What sort of limit setup do you have? Do you have the LO-X7 DSP or the AW608?
Any suggestions as to what I might try?

Posts: 37
Joined: Mon Dec 22, 2014 3:08 am

Re: Z axis limit switch question.SOLVED!!

Postby reeser » Tue May 05, 2015 9:26 pm

Hi All:

I finally figured out the limit switch issue. Thanks to Andre (bloq on the forum) He sent me a file from Sinjoe of a 26 page document for the AWC708C DSP which is essentially the same as the LO-X7 from LightObject.
I was unaware that such a document existed and nobody on the LO forum ever mentioned it either. I have been struggling with the AW608 Manual which is what is supplied when you buy the DSP from them.(which is considerably different than the LO-X7 DSP)
It turns out that if you push the "stop" and "shift" keys simultaneously it opens up a whole list of Manufacturing Parameters.
Most things like water protect, Lid close, hard limit settings are set to a function called "close" which apparently disables that function in the controller. If you change the function to "open" it enables that function. Simple as that!!
Once I changed the X,Y, ans Z hard limit parameters to "open" everything worked fine.
Once you know the magic decoder "stop-shift" trick life becomes much easier.
Am I the only one on the planet that didn't know this?
I published the same question on the LightObject Forum several days ago, and got one response suggesting "run it without limit switches".

How disappointing :x

Thanks to Scott who at least tried to help :) and thanks to Andre who tipped me off on the Sinjoe document.
Posts: 37
Joined: Mon Dec 22, 2014 3:08 am

Return to Commercial DSP CO2 Laser Engraving/ Cutter Controller

Who is online

Users browsing this forum: No registered users and 1 guest